Perl scripts, CPAN and Archiveopteryx

Perl scripts may want to access Archiveopteryx, either via IMAP, POP, Managesieve or SMTP, using various CPAN modules. This page will list problems as we become aware of them.

The CPAN module Authen::SASL::Perl uses broken Digest-MD5 authentication up to at least version 2.10. Version 2.10 is included in Debian, Ubuntu and perhaps other linux distributions. 2.12 seems to be correct.

As a workaround, you may prefer to disable auth-digest-md5.

In case of questions, please write to info@aox.org.

Relevant links

About this page

Last modified: 2010-11-19
Location: aox.org/clients/perl